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Disclaimer and Terms 

(1) Before using these instructions, it is the responsibility of the system manufacturer to observe the 

specifications of the individual components and the basic safety precautions. Only a qualified 

electrician or an electrically trained person, under the supervision of a qualified electrician, should carry 

out the installation and wiring of the individual components. It is imperative that the appropriate safety 

devices are used! (LS FI / RCD). Before starting work, it is essential to determine that there is no live 

voltage connected and to guarantee this remains the case for the duration of the work. 

(2) In order to set up the system safely, please be sure to observe the safety instructions contained in the 

instructions for the individual products and refer to the respective products. You will always find these in 

the instructions under “Safety Precautions” or “Safety Instructions”. 

(3) The system manufacturer is obliged to comply with the norms or national standards of the components 

of the machine. 

(4) Redistribution of this document or parts of this document is not permitted without the consent of 

Oriental Motor (Europa) GmbH. 

(5) The information and versions of the software contained in this document are current as of November 

15th. The information in this document is not updated regularly and is subject to change without notice. 

(6) This document serves only as an example for orientation during initial commissioning. Oriental Motor 

(Europa) GmbH assumes no liability for the functionality of the program or any consequences or 

damage caused by programs created with the help of this example program. 
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Connection model and operating instructions 

■Products 

・ PROFINET compatible Version of the AZ series with AC or DC power supply 

* Product knowledge of the AZ series is helpful during setup. 

■ Preparation 

 Please have a copy of the operating instructions for reference. 

The latest version can be downloaded from the Oriental Motor homepage. 

AZ series 

PROFINET compatible driver 

① HM-60252 AZ-Series Function Edition (E) 

② HM-60411 
AZ-Series Operation Manual (E) 

PROFINET 



5 

System configuration 

AZD-KPN 

MEXE02 

USB 

cable 

Product Model Version 

CPU SIMATIC S7-1200 

6ES7 212-1AE40-0XB0(Siemens) 

Ver4.2 

Software (Siemens) TIA Portal V15.1 

AZ series driver AZD-KPN 24 VDC 

Data setting software MEXE02 Ver 4.4.0.0 

Ethernet 

cable 

* The 24 VDC version is specified in this manual. 

Ethernet 

cable 

TIA Portal 
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Example of an IP address 

Note: 

Each IP address may only be used once in a network. 

IP-address：192.168.0.3 

 

 

 

 

 

 

 

αSTEP 

AZ series 

AC driver 

SPS 

 

 

 

 

 

 

 

αSTEP 

AZ series 

AC driver 

IO Device IO Device 

IP-address：192.168.0.2 

IP-address ：192.168.0.1 
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Adjust the Windows IP setting 

① 

② 

③ 

Change the setting of the IP address to be used: 

 

① Click the Windows button in the lower left corner of the taskbar 

     Search for “control panel” 

② Click on [Netzwork and Sharing Centre]. 

③ Click on [Ethernet] of the network, connected to the PLC. 
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Adjust the Windows IP setting 

④ Click on [Properties]. 

⑤ After selecting [Internet Protocol Version 4 (TCP / IPv4)], click [Properties]. 

⑥ Set the IP address and the subnet mask.  

    In this manual, the IP address is “192.168.0.100”. 

    Set the subnet mask to “255.255.255.0”. 
Device IP address Subnet mask 

PC 192.168.0.100 255.255.255.0 

SPS 192.168.0.1 255.255.255.0 

AZD-xPN 192.168.0.2 255.255.255.0 

④ 

⑤ 

⑥ 
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Retrieving GSD files 

AZD-CPN 230 VAC Version 

AZD-KPN 24/48 VDC Version 

* Files differ depending on the version. 

A GSD file is a configuration file that configures communication settings for 

PROFINET devices. Please download the GSD file from our website in advance. 

https://www.orientalmotor.de/ 

Click 
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Create a new project 

Start the TIA Portal: 

 

① Define the project name, the path and the author. 

② Click on [Create]. 

③ Click on [Project view]. 

③ 

① 

② 
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Controller selection 

① 

② 

③ 
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Install the GSD files 

Install the downloaded GSD file for the desired driver. 

 

① Click on [Options> Manage general station description (GSD)]. 

② Select the folder in which the GSD file is to be saved  

     and tick the check box for the GSD files to be installed. 

③ Click on [Install]. 

① 

② 

③ 
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Add AZ Driver 

Add the driver installed under “Install the GSD file”: 

 

① Double-click on [Devices & networks]. 

② In the [Catalog] directory, double-click the driver you want to use and add the driver. 

     Place it in any position. 

② 

① 

※ Both AC and DC GSD files are installed. 

※ 
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Add AZ Driver 

Specify the driver's connection destination: 

 

③ Drag a connection from the PLC “PLC_1” to the AZD-xPNx driver. 

④ When the connection has been established,  

     the driver AZD-xPNx is assigned to the PLC “PLC_1”. 

③ ④ 
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IP address settings 

① Click on the PLC in the red frame. 

② Click on [Properties> General> Project Information] and change the name to any name. 

     “PLC_1” is assigned in this manual. 

③ Set the IP address and the subnet mask under [PROFINET interface> Ethernet addresses]. 

     In this manual the IP address: 192.168.0.1 and the subnet mask: 255.255.255.0 are defined. 

     Also, change the name, IP address, and subnet mask on the driver side to match. 

① 

② 

③ 

Parameter PLC Driver 

Name PLC_1 AZD-PNDC 

IP address 192.168.0.1 192.168.0.2 

Subnet mask 255.255.255.0 255.255.255.0 
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Tag settings 

Ladder diagrams use variables, also called “tags”, to control devices. The address of the I / O 

device must be assigned to these tags. To do this, set the start address of the driver here: 

 

① Double-click on [Ungrouped devices> AZD-PNDC> Device configuration]. 

② Display the tab [Device view> Device overview]. 

③ Check the input address (I address) and the output address (O address). 

     In this manual, both the I address and the O address are set to “2”. 

① 

② 

③ 
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Tag settings 

Create a tag that will be assigned to a register address: 

 

④ Double-click on [PLC tags> Add new tag table] to create a tag table and assign a name.  

     Here: “AZD-xPN I/O Register” 

⑤ Double-click on the created variable table to create the desired variables. 

④ 

Data type Format 

Bool 1 [Bit] 

Word 2 [Byte] 

Dword 4 [Byte] 

Operand identifier Description 

Q PLC output (Input to the driver) 

I PLC input (Output from the driver) 

M Internal PLC flag 

⑤ 
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Tags for the output registers 

Byte Size (byte) Description 

0,1 2 Remote I/O (R-IN) 

2,3 2 Operation data number selection 

4,5 2 Fixed I/O (IN) 

6,7 2 Direct data operation operation type 

8~11 4 Direct data operation position 

12~15 4 Direct data operation speed 

16~19 4 Direct data operation starting/changing rate 

20~23 4 Direct data operation stopping deceleration 

24,25 2 Direct data operation operation current 

26,27 2 Direct data operation forward destination 

28,29 2 Reserved 

30,31 2 Read Parameter ID 

32,33 2 Write request 

34,35 2 Write parameter ID 

36~39 4 Write data 

Create the tags for the output registers: 

 

Continued on next page 
Tags: Output Data 

Information on the type to be set under [Data type] can 

be found in the following table: 

2 [Byte] for “Word” 

4 [Byte] for “DWord” 

I/O Data output (Master → Driver) 
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Tags for the input registers 

Byte Size (byte) Description 

0,1 2 Remote I/O (R-OUT) 

2,3 2 Op.data Nr. Selection_R 

4,5 2 Fixed I/O (OUT) 

6,7 2 Present Alarm 

8~11 4 Feedback Position 

12~15 4 Feedback Speed (Hz) 

16~19 4 Command Position 

20,21 2 Torque monitor 

22,23 2 CST operating current 

24~27 4 Information 

28,29 2 Reserved 

30,31 2 Read parameter ID_R 

32,33 2 Read/write status 

34,35 2 Write parameter ID_R 

36~39 4 Read data 

40~43 4 Assignable monitor 0 

44~47 4 Assignable monitor 1 

48~51 4 Assignable monitor 2 

52~55 4 Assignable monitor 3 

Create the tags for the input registers: 

 

Tags: Input Data I/O Data output (Driver → Master) 
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Variables with bit addresses 

Byte Bit Name Description 

5 

0 FW-JOG Execute JOG operation in the forward direction. 

1 RV-JOG Execute JOG operation in the reverse direction. 

2 Reserved A value is disregarded. 

3 START Execute stored data operation. 

4 ZHOME Eecute high-speed return-to-home operation. 

5 STOP Stop the motor. 

6 FREE 

shut off the motor current to remove the motor excitation.  

In the case of an electromagnetic brake motor, the 

electromagnetic brake is released. 

7 ALM-RST Reset the alarm being generated presently. 

4 

8 TRIG Execute direct data operation. 

9 TRIG-MODE 

Set the judgment level for the TRIG. 

0: Start at ON edge 

1: Start at ON level 

10 ETO-CLR Release the ETO-mode. 

11 Reserved A value is disregarded. 

12 FW-JOG-P Execute inching operation in the forward dir. 

13 RV-JOG-P Execute inching operation in the reverse dir. 

14 FW-POS Execute continuous operation in the forward dir. 

15 RV-POS Execute continuous  operation in the reverse dir. 

You can also create variables bit by bit, this is useful for controlling signals: 

 

When creating bit-by-bit variables, pay attention to the placement of the bits in the addresses. 

Register based tags 

Bit-by-bit tags I/O Data output (Master → Driver) 

< 
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Tags for test mode 

Operand identifier Description 

Q PLC output (Input to the driver) 

I PLC input (Output from the driver) 

M Internal PLC flag 

Define variables to control the internal PLC flags. 

The following internal flag are used in the test mode. 

Data type Format 

Bool 1 [Bit] 

Word 2 [Byte] 

Dword 4 [Byte] 



22 

Create ladder diagram 

Control of the motor with PROFINET communication. 

 

1) Operation by I / O control 

Control of the fixed I / O and remote I / O signals with PROFINET IO via bits. 

In this manual, [FW-POS] for continuous operation and the stop signal [STOP] are 

controlled via the network. 

 

Output signals can be assigned via a branch in order to display the status. 

 

2) Operation by DDO 

Control with the “Direct Data Operation” registers with PROFINET IO. 

The motor is controlled by the signals [TRIG] and [TRIG-MODE]. 

This manual explains the process from setting the operating data to starting operation. 

 

It is also possible to start the process just by updating a value. 
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Create I/O network 

1) Create a network that uses I / O functions. 

 

① Double-click on [Program blocks> Main [OB1]]. 

② Click on the point where you want to place the components in “Network 1”. 

③ Click on the desired Boolean component to place it there. 

Boolean 

output 
Boolean 

input Function Branch 

① 

② 
③ 
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Create branch 

Assign the tags created on page 19 to the branches of the ladder diagram: 

 

④ Double-click on the component's <??.?> And click on the symbol displayed to show 

     the list of variables. 

     Select the tags from the list - as shown in the following figure: 

MI_BIT0 FixedIO_IN_FW-POS 

MI_BIT1 

FixedIO_IN_STOP ④ 

See pages 16 to 20 to learn how to set tags. 

Uses internal flag for the 

test mode 
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Create branch for I/O control 

Compile the created ladder diagram: 

 

⑤ Click on [Compile]. 

⑥ If the compiling completes successfully, the message 

     “Compiling finished (errors: 0; warnings: 0)” will be shown 

      Check the displayed content for errors. 

⑤ 

⑥ 
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Create branch for DDO control 

2) Create a branch for DDO operation: 

① Create a branch in “Network 2” as in the previous example I / O branch.To set the travel data, 

     use “MOVE” to output the input values. 

② Click on [Empty box] to place it on the branch in “Network 3”. 

③ Double click on the placed [Empty box] “??” and enter “MOVE”. (6 times) 

④ Set the values and tags that correspond to the following table for the input (IN)  

     and the output (OUT1) of each MOVE block. 

⑤ Compile using the same procedure as on page 24. 

MI_BIT2 

MI_BIT3 

FixedIO_IN_TRIG 

FixedIO_IN_TRIG-MODE 

DDO_Type DDO_Pos DDO_Vel 

DDO_Crnt DDO_Dec DDO_Acc 

Please refer to the instruction manual for more information 

Name Tag(OUT1) Value (IN) Remarks 

Operation type DDO_Type 2 Incremental (based on FB) 

Target Position DDO_Pos 10000 [step] 

Speed DDO_Vel 2000 [Hz] 

Acceleration DDO_Acc 1000000 [0.001kHz/s] 

Deceleration DDO_Dec 1000000 [0.001kHz/s] 

Operation Current DDO_Crnt 1000 [0.1%] 

③ 

④ 

① 

② 
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Device communication 

Configure the communication settings for the device to be used:     

 

The device connected to the Ethernet cable is displayed in the menu. 

① Open [Online access] and open the folder for the Ethernet connection that is connected to the 

     device. In this manual, open [Intel (R) Ethernet Connection (4) I1219-LM]. 

② Double-click on [Update accessible devices] to find the detected devices. 

     They are displayed as [New Device [xx-xx-xx-xx-xx-xx]]. 

     [xx -...] is the MAC address, which is different for each device. 

     If communication settings have already been configured, the device name and IP address are 

     displayed. 

① 

② 
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IP address setting 

Set the driver's IP address: 

 

① Double-click on PLC (here: plc_1) and then [Device> Online & diagnostics]. 

② Click on [Functions> Assign IP address]. 

③ Specify the IP address and subnet mask specified on page 14 and 

     click on [Assign IP address]. ※ 

① 

② 

③ 

※If the IP address has already been set in the PLC, you may not be able to change it. 
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PROFINET device name 

Set the device name: 

 

① Click on [Functions> Assign PROFINET device name]. 

② Set the device name. “PROFINET device name” can only be assigned in lower case letters. 

     Set “PLC_1” - from page 14 - as “plc_1”. 

③ Click on [Assign name]. 

④ Set the IP address and the device name for the driver in the same way. 

② 

① 

③ 

④ 
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Load into device 

② 

③ 

① 

Load the created project into the PLC: 

 

① Check the items to be confirmed before downloading. 

② Click on “PLC_1” to download it. 

③ Click on [Download to device]. 

Checklist Ref. 

Are the IP addresses of the PC, PLC and driver set to 192.168.0.x? P.6-7 

P.14,27 

Have the correct connections been used for the devices? 

Be careful with PLCs with multiple connections. 

P.13 

Do the PROFINET device names specified in the project and on the 

devices match? 

P.14,28 
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Download to device 

④ The [Extended download] window opens. 

      Please set each item using the following table. 

⑤ Click on [Start Search]. 

⑥ Select the target PLC for loading. 

⑦ Click on [Load]. 

      The confirmation screen will be displayed. 

④ 

⑤ 

⑦ 

⑥ 

Settings Set values 

[Type of PG/PC interface] PN/IE 

[PG/PC interface] 
Please select the interface according to your environment 

This manual uses [Intel (R) Ethernet Connection I219-LM]. 

[Connection to Interface/Subnet] 
PN / IE_1 

Select the communication name connected on page 13. 
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Download to device 

⑧ Click on the confirmation screen as shown below to complete the download. 

⑧ 

The project download is now complete. 
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Demo mode: Monitor 

① 

Establish an online connection with the PLC for test operation: 

 

① Click on [Go online]. 

② Check if the device is online and click [GoOnline]. 

② 
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Demo mode: Monitor 

When you go online the title will turn orange. 

If the symbol in frame “A” is green, the TIA Portal project and the PLC settings will match. 

If the symbol is not green, carry out the following steps to match the settings in the project with 

the PLC: 

 

① Click on [Go offline]. 

② Click on [PLC_1 [CPU 1212C DC / DC / DC]] to select it. 

③ Click [Download to device] to download. (Same procedure as p. 29 ~ 31) 

② 

③ 

A 

① 
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Demo mode: Monitor 

Set the ladder diagram screen to monitor state in order to operate the program: 

 

① By default, the PLC is not in the RUN state 

     Click [Start CPU],  then click [OK] on the warning screen. 

② Click the [Monitoring on / off] symbol to start monitoring. 

① 

② 
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Demo mode: I/O Control Branch 

Check the operation of the motor with the ladder diagram programme created on p.22-24. 

※ Please check the security of your ambient in advance. The motor turns. 

 

① Right-click on [MI_BIT0] and click on [Modify> Modify to 1]. [FixedIO_IN_FW-POS] is switched on. 

     As a result, the FW-POS signal is set in the driver and the motor rotates continuously in the  

     FWD direction. 

② When MI_BIT1 is turned on in the same way, [FixedIO_IN_STOP] is turned on. 

     As a result, the STOP signal is input to the driver and the continuous operation is stopped. 

③ After you have checked the operation of the motor, right-click on [MI_BIT0] and [MI_BIT1]. 

    Select [Modify> Modify to 0] to turn off the signals in the driver. 

① 

② 

The checking of the motor operation by I/O branch is now finished. 
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Demo mode: DDO Branch 

① 

② 

※2 
※2 The trigger mode can be set by switching [MI_BIT3] on and off. In 

this manual it is set to OFF (0). When switched off, DDO operation 

begins on the positive edge of [FixedIO_IN_TRIG]. 

Please refer to the instruction manual for more information. 

※1 The representation of the output value OUT1 is set to a 

hexadecimal number by default. 

Change representation to decimal: 

         1) Right-click the output value 

         2) Click on [Display format> Block> Decimal] 

※1 

Direct data operation is performed using the ladder diagram created on page 25. 

※ Please check the security of your ambient in advance. The motor turns. 

 

① Make sure that the [OUT1] value of each MOVE corresponds to the value of IN. 

     At this point the value for the driver's direct data operation is set. 

② If [MI_BIT2] is switched on, [FixedIO_IN_TRIG] is switched on and DDO operation is started. 
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Demo mode: Monitor register values 

If you want to monitor the driver value, you can check it by following the steps below: 

① Double-click on [PLC tags> AZD-xPN I/O-Register] to open it. 

② Click [Monitor all] to check the register values shown. 

① 

② 
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Monitor register values 

③ Rotate the motor with the ladder diagram: 

     The value of FeedbackPos (actual position) is increased. 

 

By using the appropriate internal 

flags in the ladder diagram. 

 

View of all variables in the  

corresponding window. 

324723 dec 

335533 dec 

③ 
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Appendix: Import/Export of Tags 

A created variable table can be imported or exported: 

 

① Importing a previously generated variable table. 

     For this manual [PLC tags> Add new tag table]. 

② Click on [Import]. 

③ Select the file to be imported and click on [OK]. 

 

The imported tag file is displayed under [PLC tags].This manual reads the export data from the 

tag table created on page 19. 

Click ④ to export. 

① 

② 

③ 

④ 
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Appendix: Write Parameter 

It is possible to write any parameters in the driver via PROFINET communication. The following 

PROFINET IO registers must be used to write a parameter: 

 

 

 

 

 

Example for changing the base current (parameter ID: 294) from 100.0 [%] to 10.0 [%]. 

① Create a MOVE component to transfer the value and a branch that activates the write request.

② Activate [Monitoring] and switch on [MI_BIT4] to write the parameters. 

 

The successful execution of the command can be checked with the help of the monitors. 

② 

Parameter ID 
Name Range Default Value 

Dec Hex 

294 0126h Base Current 0~1000(1=0.1%) 1000 100 

① 

※ Set the WR-REQ bit in the ladder diagram. 

Bit0 in the WriteReq register was created as a 

separate bit variable. 

※ For details, see the instruction manual. 

Used 

Bytes 

Size 

(Byte) 

Name Comment 

32,33 2 WriteReq Write request WR-REQ ON. 

34,35 2 WritePrmID Address of the register to be written 

36~39 4 WriteData Value to be written into the register 
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Appendix: Read Parameter 

It is possible to read any parameters via PROFINET communication. 

The following PROFINET IO registers must be used to read a parameter. 

 

 

 

 

 

Reading the base current (Base Current - Parameter-ID: 294). 

① Create a branch in which the parameter ID to be read and the value are temporarily stored. 

② If [Monitoring] is switched on, you can check whether the current value in ReadData is read 

     correctly. “1000” is read before the change, when the parameter - as shown on page 40 – has 

     been changed, “100” is read.  

 

The successful execution of the command can be checked with the help of the monitors. 

① 

② 

※ For details, see the instruction manual. 

Direction Bytes 

in use 

Size 

(Byte) 

Name Remarks 

Ausgabe (Host → Treiber) 30, 31 2 ReadPrmID Address of the register to be read 

Eingabe (Treiber → Host) 36～39 4 ReadData Value that was read out. 

Parameter ID 
Name Range Default 

S. 41 

Value Dec Hex 

294 0126h Base Current 0~1000(1=0.1%) 1000 100 

Create a buffer to store the 

reading.Build it as needed. 
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History Content 

March 2021 Newly created 

Hint: 

 
We are available for you: 00800 22 55 66 22 

 

Mon-Thu from 8:00 a.m. to 4:30 p.m., Friday: 8:00 a.m. to 3:00 p.m. 

 

Oriental Motor (Europa) GmbH. https://www.orientalmotor.eu/ 


